Enhanced Interior Gateway Routing Protocol atau disingkat EIGRP adalah salah satu routing protocol yang digunakan untuk menghubungkan jaringan antar router secara dinamik. EIGRP merupakan protokol routing yang hanya dapat digunakan pada router- router cisco dan termasuk ke dalam distance vector routing protocol.
Untuk melakukan konfigurasi routing eigrp, setidaknya terdapat dua langkah yang harus dilakukan, yakni mengaktifkan routing eigrp dan mengadvertise network yang terhubung dengan router.
router eigrp [ASN]
network [network_address]
network [network_address] [wildcard mask]
Device | Interface | IP Address | Subnetmask | Gateway |
---|---|---|---|---|
R1 | FastEthernet 0/0 | 192.168.1.254 | 255.255.255.0 | N/A |
Serial 2/0 | 100.100.100.1 | 255.255.255.252 | N/A | |
Serial 3/0 | 100.100.100.5 | 255.255.255.252 | N/A | |
R2 | FastEthernet 0/0 | 192.168.2.254 | 255.255.255.0 | N/A |
Serial 2/0 | 100.100.100.6 | 255.255.255.252 | N/A | |
Serial 3/0 | 100.100.100.9 | 255.255.255.252 | N/A | |
R3 | FastEthernet 0/0 | 192.168.3.254 | 255.255.255.0 | N/A |
Serial 2/0 | 100.100.100.2 | 255.255.255.252 | N/A | |
Serial 3/0 | 100.100.100.10 | 255.255.255.252 | N/A | |
PC 1 | FastEthernet 0 | 192.168.1.1 | 255.255.255.0 | 192.168.1.254 |
PC 2 | FastEthernet 0 | 192.168.2.1 | 255.255.255.0 | 192.168.2.254 |
PC 3 | FastEthernet 0 | 192.168.3.1 | 255.255.255.0 | 192.168.3.254 |
//masuk ke mode konfigurasi
Router>enable
Router#configure terminal
//mengubah hostname
Router(config)#hostname R1
//konfigurasi ip address
R1(config)#interface fa0/0
R1(config-if)#ip address 192.168.1.254 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#interface s2/0
R1(config-if)#ip address 100.100.100.1 255.255.255.252
R1(config-if)#no shutdown
R1(config-if)#interface s3/0
R1(config-if)#ip address 100.100.100.5 255.255.255.252
R1(config-if)#no shutdown
R1(config-if)#exit
//konfigurasi eigrp
R1(config)#router eigrp 1
R1(config-router)#network 192.168.1.0 0.0.0.255
R1(config-router)#network 100.100.100.0 0.0.0.3
R1(config-router)#network 100.100.100.4 0.0.0.3
R1(config-router)#no auto-summary
R1(config-router)#exit
//menyimpan konfigurasi router
R1(config)#do write
Building configuration...
[OK]
R1(config)#
//masuk ke mode konfigurasi
Router>enable
Router#configure terminal
//konfigurasi hostname
Router(config)#host R2
//konfigurasi ip address
R2(config)#interface fa0/0
R2(config-if)#ip address 192.168.2.254 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#interface s2/0
R2(config-if)#ip address 100.100.100.6 255.255.255.252
R2(config-if)#no shutdown
R2(config-if)#interface s3/0
R2(config-if)#ip address 100.100.100.9 255.255.255.252
R2(config-if)#no shutdown
//konfigurasi eigrp
R2(config-if)#router eigrp 1
R2(config-router)#network 192.168.2.0 0.0.0.255
R2(config-router)#network 100.100.100.4 0.0.0.3
R2(config-router)#network 100.100.100.8 0.0.0.3
R2(config-router)#no auto-summary
R2(config-router)#exit
//menyimpan konfigurasi router
R2(config)#do write
Building configuration...
[OK]
R2(config)#
//masuk ke mode konfigurasi
Router>enable
Router#configure terminal
//mengubah hostname
Router(config)#hostname R3
//konfigurasi ip address
R3(config)#interface fa0/0
R3(config-if)#ip address 192.168.3.254 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#interface s2/0
R3(config-if)#ip address 100.100.100.2 255.255.255.252
R3(config-if)#no shutdown
R3(config-if)#interface s3/0
R3(config-if)#ip address 100.100.100.10 255.255.255.252
R3(config-if)#no shutdown
//konfigurasi eigrp
R3(config-if)#router eigrp 1
R3(config-router)#network 192.168.3.0 0.0.0.255
R3(config-router)#network 100.100.100.0 0.0.0.3
R3(config-router)#network 100.100.100.8 0.0.0.3
R3(config-router)#no auto-summary
R3(config-router)#exit
//menyimpan konfigurasi router
R3(config)#do write
Building configuration...
[OK]
R3(config)#
show ip route
show ip route eigrp
R1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
100.0.0.0/30 is subnetted, 3 subnets
C 100.100.100.0 is directly connected, Serial2/0
C 100.100.100.4 is directly connected, Serial3/0
D 100.100.100.8 [90/21024000] via 100.100.100.6, 00:00:37, Serial3/0
[90/21024000] via 100.100.100.2, 00:00:08, Serial2/0
C 192.168.1.0/24 is directly connected, FastEthernet0/0
D 192.168.2.0/24 [90/20514560] via 100.100.100.6, 00:00:37, Serial3/0
D 192.168.3.0/24 [90/20514560] via 100.100.100.2, 00:00:08, Serial2/0
R1#show ip route eigrp
100.0.0.0/30 is subnetted, 3 subnets
D 100.100.100.8 [90/21024000] via 100.100.100.6, 00:00:50, Serial3/0
[90/21024000] via 100.100.100.2, 00:00:21, Serial2/0
D 192.168.2.0/24 [90/20514560] via 100.100.100.6, 00:00:50, Serial3/0
D 192.168.3.0/24 [90/20514560] via 100.100.100.2, 00:00:21, Serial2/0
Tulis Komentar